Newbie questions about Pliant

Newbie questions about Pliant

Release 66: How to debug various servers configuration

Release 66 contains a very powerfull tracing mechanism
that enables you to detect what your server is doing.
Here is how to use it:
Message posted by hubert.tonneau on 2001/11/27 09:49:02
Some time ago, Ingo Hohmann reported failure to properly setup a Pliant
mail server (I think the mail was not forwarded).
Release 66 contains the long awaited answer.

Log on your site with administrator account,
the select the 'trace' link at the buttom of the the Pliant home page on
your computer, or select /pliant/protocol/http/trace.html page,
and finally press the 'Display' button.

Now you will see the trace of all your server activity (DNS answering,
mails coming in and beeing forwarded, etc)
This is quite a lot of stuff, so you can fill some lines before pressing
the 'Display' button, and then you will see only messages starting with
one of the lines you specified.

Have fun guys.
Message posted by michel on 2001/11/27 13:03:17
It does not work on my computer (win98) but al other features (i had tseted) work fine
Message posted by maybe Hubert Tonneau on 2001/11/27 13:49:27
I don't understand how it could not work under Win32: the trace mechanism
is not operating system related.

Do you get a compile error, or do you get nothing in the trace ?
In order to see something in the trace, you have to open two browser windows,
one displaying the trace, then browse your site in the second one, so that you
should see the corresponding messages in the trace window.
Message posted by maybe Hubert Tonneau on 2001/11/27 16:22:14
I know what I forgot to specify: the tracing mechanism is ignored (does
nothing) at debugging level 0.
This is because each 'trace' instruction consumes a bit of processing
power, even when no trace is active.
Message posted by maybe Hubert Tonneau on 2001/11/29 17:02:00
Michel, did you manage to get the trace working ?
Ingo, did you manage to solve your mail configuration problem using the trace ?
Message posted by michel on 2001/11/30 17:07:14
Yes it runs, I have not understood that it displays the new connection but not the existing ones.
Bu I what is the utility of the windows "path to trace : " I have left it blank.
Message posted by maybe Hubert Tonneau on 2001/11/30 17:23:20
> Bu I what is the utility of the windows "path to trace : " I have left it blank.

It enables you to filter the messages: only the ones starting with one
of the filters you specified will be displayed.
If you leave it blank, then all messages will be displayed.
Message posted by maybe ingo.hohmann on 2001/12/04 10:30:17
Hi Hubert,

I just tried to install Release 66, and that's what I get ..

Pliant path is /home/ingo/pliant/
precompiling Pliant (debugging level 0)
no such file
no such file
  this computer name is smrgol in domain 2b1.de
  security path is file:/home/ingo/pliant_security/
  data path is file:/home/ingo/pliant_data/
  memory used: 2001 Kb  consumed: 2628 Kb  maximum: 2628 Kb
precompiling Pliant (debugging level 1)
no such file
no such file
  memory used: 2406 Kb  consumed: 2948 Kb  maximum: 2948 Kb
precompiling Pliant (debugging level 2)
no such file
no such file
  memory used: 3108 Kb  consumed: 3716 Kb  maximum: 3716 Kb
  physical memory available is: 127072 Kb

And I can't start the server afterwards, it just exits without
any message.


Any ideas?

Ingo
Message posted by hubert.tonneau on 2001/12/04 11:15:26
The 'no such file' message is a rather non meaningfull Pliant message
from module /pliant/language/basic/plugin.pli
I just removed it.

On the other hand, I just tryed to move /pliant/ to my home directory,
the typed:
  /home/me/pliant/pliant/install/install
  /home/me/pliant/binary/pliant-debug1.exe module /pliant/protocol/http/server.pli command 'http_server configure'
and everything runs fine (I get the query about the administrator account).

After running the install script, you should check that you have three fresh
.dump files in /home/me/pliant/binary/
Message posted by maybe ingo.hohmann on 2001/12/04 20:20:36
Uhm, yes, I tried to start the server using ../run.pli,
and this doesn't work. 

Starting it directly works fine, though.

I assume run.pli is superseded by the plugins? How can I
find more information about using them?

kind regards,

Ingo
Message posted by maybe Hubert Tonneau on 2001/12/04 21:33:09
After configuring the server, the command
  /home/me/pliant/binary/pliant-debug1.exe module /pliant/fullpliant/run.pli
works just fine for me.

You should have no plugin at the beginning, so assuming that Pliant is
installed in /home/me/ then you should have no /home/me/pliant/custom/
directory.
Message posted by maybe Terry Kennedy on 2001/12/07 21:15:24
where can I go to learn the lanuage of the computer so I can make it do ,
what I want. I am 49years old just started computers 1 year ago.
I,am totaley  consumed with it. I just dodn;t want to simply oped a window .
I want to know what it is about and how it works .I hope that I,am not bothering anyone.With such a simple request but there seem no one here where 
I am cares to help or want to.I would like to learn how to program ,
but also I would like to learn the lanuage and how it applies to the world ,
of computers so coul some please put me on the right track thank you .
sorry if I have invaded you privicy of this room to enter this request
thank you  Terry 
Message posted by maybe Hubert Tonneau on 2001/12/08 12:33:16
This forum is the right place to ask, and you are welcome.

We don't currently have something usable for a real computer newbie,
but we have to improve in this area, so you are free to ask.
The only thing is that we cannot give you a smooth path to follow, so you have
to do it the other way round: read what's available, then try to do something
and just ask about what prevents you to do it. You simply have to start with
very simple things so that your questions are precise enough so that we can
give answers that fit within one page or so.
Message posted by ingo.hohmann on 2002/01/09 07:23:35
About my email server problems:

This happened on an NT 4.0 box, that I don't have access to any more, but I
tried rel. 70 on a win2000 box, and it seems to work fine now.