Newbie questions about Pliant

Newbie questions about Pliant

problems with "mount procedure"

In the past i used "mount" procedure and it runed perfectly.
Now it doesn't realy work, but I doesn't know since what release.
Message posted by michel on 2002/01/28 16:18:15
In the file browser I can find my mounted directory, subdirectories and list of files.
But if I click on a file (.page, .html or .txt) the result is a blank page.
If I ask for view I have the same result, but I can edit the file!!
If I try to load the file with its URL "localhost/mounteddirectory/subdir/file.html"
the result is a 404 error page.

If i give the relative path with "mounteddirectory/subdir/" instead of /file: a.s.o."
 for one of my site and
when i ask for it ithe result is a message with "this file doesn't exist"

Al of these worked in the past (remember my speach at the annual meeting)
Message posted by maybe Hubert Tonneau on 2002/01/30 12:32:51
I've added a 'Mode' field in the site areas definition that was not available
a year or so ago. If you want the same behaviour as previously, you have to set
it to 'Open'.
Might solve your problem.
Message posted by michel on 2002/01/30 18:45:37
Sorry but it doesn't work (after stopping servers, precompiling all, restarting the server)
Message posted by maybe Patrice Ossona de Mendez on 2002/02/01 06:22:11
Hubert, the problem seems to be related to the "mount" function, not to the area
system.
Message posted by pom on 2002/02/01 09:56:27
The problem concerns the "file_query".
Here is a small program showing the bug under linux:

module "/pliant/language/stream/multi.pli"
module "/pliant/language/stream.pli"
pliant_multi_file_system mount "/x/" "/tmp/" pliant_os_file_system
gvar FileInfo info
info := file_query "/x/toto.page" standard
if info=undefined
  console "undefined" eol
gvar Stream s
s open "/x/toto.page" in+safe
if s<>failure
  console "open ok" eol

-----------------
Then, assuming /tmp/toto.page exists, I get the messages:
undefined
open ok

The open worked (and thus the edit works with the file_browser), but the
file_query doesn't (and hence the send_static_file fails)
Message posted by pom on 2002/02/01 10:07:46
I got the bug (or at least one). Will send a patch in code forum
Message posted by pom on 2002/02/01 10:18:36
For me, all works fine, now.