Newbie questions about Pliant

Newbie questions about Pliant

Dificulties with release 82

I have some difficulties when I call "loaaclhost" with 82 under Win XP.
Message posted by michel on 2003/03/22 15:17:00
When calling "pliant.cx" running release 82, all is OK, both with IE6 and Netscape 6.2
When, after installing release 82 on my computer under Windows XP, I call "localhost
- with IE6 I get the following message:
   "une erreur est survenue."
   "Souhaitez-vous effectuer le débogage?
   "Ligne 5"
   "Erreur:Objet attendu"
   if I answer "oui"
   after 2 screens I get the message:
   "Erreur d'exécution Microsoft JScript: Objet attendu
   And an arrow points to the line:
   "<body bgcolor="#C9CDCA" onLoad="refresh()">"
   remark: with "pliant.cx" the line is the same but no bug occurs.
   This bug occurs both with or with out "doc.style"
- with Netscape nothing occurs but
- with both browsers I've lost the rounded corner on "localhost"
Message posted by hubert.tonneau on 2003/03/22 16:09:41
Just request the following URL:
http://localhost/pliant/protocol/http/common/virtual_tree.html
and post the error message you get from Pliant HTTP server.
Message posted by michel on 2003/03/22 16:24:02
There is a bug in the dynamic page /pliant/protocol/http/common/virtual_tree.html.

Failed to compile stream_pipe   (?  ?)
  compile /pliant/graphic/filter/ijs.pli (internals) 103 3
compile /pliant/graphic/filter/ijs.pli (internals) 97 1
compile /pliant/graphic/filter/ijs.pli (internals) 97 1
compile /pliant/graphic/filter/ijs.pli (internals) 96 1
compile /pliant/graphic/filter/ijs.pli (internals) 96 1
compile /pliant/graphic/filter/ijs.pli (internals) 96 1
compile /pliant/graphic/filter/ijs.pli (internals) 96 1
parse /pliant/graphic/filter/ijs.pli (internals) 144 1
module /pliant/graphic/filter/ijs.pli
compile /pliant/graphic/filter/all.pli (internals) 31 1
compile /pliant/graphic/filter/all.pli (internals) 31 1
compile /pliant/graphic/filter/all.pli (internals) 31 1
compile /pliant/graphic/filter/all.pli (internals) 31 1
parse /pliant/graphic/filter/all.pli (internals) 32 1
module /pliant/graphic/filter/all.pli
Message posted by michel on 2003/03/22 16:26:15
!! end of message, longer not accepted by "pliant.cx"
compile /pliant/graphic/filter/io.pli (internals) 24 1
compile /pliant/graphic/filter/io.pli (internals) 24 1
compile /pliant/graphic/filter/io.pli (internals) 24 1
compile /pliant/graphic/filter/io.pli (internals) 24 1
parse /pliant/graphic/filter/io.pli (internals) 25 1
module /pliant/graphic/filter/io.pli
compile /pliant/protocol/http/common/virtual_tree.page 9 1
compile /pliant/protocol/http/common/virtual_tree.page 9 1
compile /pliant/protocol/http/common/virtual_tree.page 9 1
compile /pliant/protocol/http/common/virtual_tree.page 9 1
parse /pliant/protocol/http/common/virtual_tree.page 10 1
module /pliant/protocol/http/common/virtual_tree.page
site 'localhost' user 'root' command GET /pliant/protocol/http/common/virtual_tree.html HTTP/1.1
service HTTP request from 127.0.0.1

Message posted by hubert.tonneau on 2003/03/22 16:32:49
Try to apply the very simple patch available here:
http://pliant.cx/pliant/browse/forum/pliant.patch/0345FCT.hubert.heliogroup.fr/
Message posted by michel on 2003/03/22 16:58:44
Ok! There is no more bug and corners are rounded but ..
Is it normal tha I've to delete the 2 ".dump" files before launching "install" ?
if not, when I lauch the servers, I got a message saying that Windows 
has a problel with "pliant.exe" and the servers don't start.
Message posted by hubert.tonneau on 2003/03/22 17:07:21
> Is it normal tha I've to delete the 2 ".dump" files before launching "install" ?

The is a:
  if exist %pliant%binary\*.dump  del %pliant%binary\*.dump
line in /pliant/install/install.bat
which is expected to remove the .dump file.
I have no idea why it does not work under XP.

See if you can figure out on your own what's wrong with install.bat
Message posted by michel on 2003/03/22 17:31:07
It is not the first time that I have this problem but it's not every time.
I have it twice today but now I can not have it any more, I"ll try to look at next time it occurs.
Message posted by pom on 2003/03/22 21:46:26
Windows might lock the dump files for some reason, because it might think they
are used by some program.