Newbie questions about Pliant

Newbie questions about Pliant

Running new ui and http server together

I would like to have read-write access to my pliant database from both the old-style
http server and new-style ui server.
Message posted by maybe Boris Reitman on 2006/06/16 23:42:37
I have a website with shopping cart written in pliant.  I would like to write
admin interface using new ui interface. This means that both will have read-write
access to the database with the shopping orders.  Can I start both the new ui
and the standard http server in the same process ?  If not, how can I arrange
for two different processes to access the database without conflict ? 

Thanks,
Boris
Message posted by maybe Boris Reitman on 2006/10/05 00:14:35
Hi,

I am trying to start both the proxy service and ui client, and the http server at once,
via fullpliant run.pli script.  This is the value of constants in run.pli:


  constant auto_ui true
  constant auto_http true
  constant auto_console false

And these are the extra settings:

+---------------------------------------------------------------------------------+
| pliant | http          | port        | 8080                            | [edit] |
|--------+---------------+-------------+---------------------------------+--------|
| pliant | http          | service     | true                            | [edit] |
|--------+---------------+-------------+---------------------------------+--------|
|        |               |             | /pliant/graphic/ui/server/      |        |
|        |               |             | main.pli                        |        |
|        |               |             | /pliant/util/pml/               |        |
|        |               |             | multiplexer.pli                 |        |
| pliant | language      | recommended | /pliant/protocol/http/          | [edit] |
|        |               |             | server.pli                      |        |
|        |               |             | /pliant/protocol/http/style/    |        |
|        |               |             | default.style                   |        |
|        |               |             | /pliant/language/debug/         |        |
|        |               |             | log_database.pli                |        |
|--------+---------------+-------------+---------------------------------+--------|
| pliant | multiplexer   | port        | 8081                            | [edit] |
|--------+---------------+-------------+---------------------------------+--------|
| pliant | ui_http_proxy | port        | 8082                            | [edit] |
|--------+---------------+-------------+---------------------------------+--------|
| pliant | ui_http_proxy | service     | true                            | [edit] |
|--------+---------------+-------------+---------------------------------+--------|
| pliant | ui_http_proxy | target      | loopback                        | [edit] |
+---------------------------------------------------------------------------------+

I am running fullpliant as user 'pliant'.  Both HTTP server, and HTTP proxy
have started:

   UI HTTP proxy server is running.
   HTTP server is running.
   
Accessing port 8080 for the http server 
works fine, but accessing the ui http proxy on port 8082 doesn't work. 
The error is,

  TCP connection failed bad IP address
  server connection oops (bad IP address)

How can I set it up to work ?
Thanks,
Boris