Newbie questions about Pliant

Newbie questions about Pliant

server getting killed by redhat during start

Message posted by marcus on 2006/09/06 21:14:12
I had my pliant server running on my linux machine. Everything was fine.

I accidentally unplugged the machine. 

Now when I try to start the server it gets killed (I have deleted the dump file).

Here is the shell output:

[root@pliant root]# pliant/fullpliant 
DNS server is running.               
Killeding SMTP server. Please wait ...
[root@pliant root]# 


Any help?

I shall be obliged.
Message posted by hubert.tonneau on 2006/09/06 21:24:30
Try to untar again the Pliant tree: you might have a corrupted source file.
Message posted by marcus on 2006/09/06 21:32:04
I did. The server is still getting killed.
Message posted by marcus on 2006/09/06 21:35:12
Also, in the same machine I used to run pliant-84. But now, when I try to start the
server I get the following error

[pliant@pliant pliant]$ ./pliantServer
./pliantServer: line 3: 25344 Segmentation fault      /home/pliant/pliant/binary/pliant-debug1.exe module /pliant/install/minimal.pli module /pliant/protocol/http/server.pli command 'http_server port 8080'
Message posted by hubert.tonneau on 2006/09/06 21:36:20
Then you might try:
pliant verbose 2 module /pliant/fullpliant/run.pli
Message posted by marcus on 2006/09/06 21:49:10
The last lines of my debug file are

....
run code generator function generate_debugging_info /pliant/language/debug/rec
run code generator function optimize_conclude  in section pliant optimizer con
execute /pliant/fullpliant/run.pli (internals) 78 1

Remote execution server is running.
Message posted by marcus on 2006/09/06 22:11:28
Please ignore my last message.

Below is the tail of the output I get

error 3:
  Failed to compile new   ('Str'  ?)
  compile /pliant/language/type/set/list.pli (internals) 245 72
compile /pliant/language/type/set/list.pli (internals) 245 61
compile /pliant/language/type/set/list.pli (internals) 245 61
compile /pliant/language/type/set/list.pli (internals) 245 24
compile /pliant/language/type/set/list.pli (internals) 245 24
compile /pliant/language/type/set/list.pli (internals) 245 5
compile /pliant/language/type/set/list.pli (internals) 245 5
compile /pliant/language/type/set/list.pli (internals) 245 5
compile /pliant/language/type/set/list.pli (internals) 168 1
compile /pliant/language/type/set/list.pli (internals) 168 1
execute /pliant/language/debug/trace.pli (internals) 129 11
compile /pliant/language/debug/trace.pli (internals) 129 5
compile /pliant/language/debug/trace.pli (internals) 129 5
compile /pliant/language/debug/trace.pli (internals) 128 1
compile /pliant/language/debug/trace.pli (internals) 128 1
compile /pliant/language/debug/trace.pli (internals) 127 3
compile /pliant/language/debug/trace.pli (internals) 127 3
compile /pliant/language/debug/trace.pli (internals) 127 1
compile /pliant/language/debug/trace.pli (internals) 127 1
compile /pliant/language/debug/trace.pli (internals) 126 1
compile /pliant/language/debug/trace.pli (internals) 126 1
compile /pliant/language/debug/trace.pli (internals) 126 1
compile /pliant/language/debug/trace.pli (internals) 126 1
parse /pliant/language/debug/trace.pli (internals) 133 1
module /pliant/language/debug/trace.pli
compile /pliant/install/ring2.pli (internals) 79 1
compile /pliant/install/ring2.pli (internals) 79 1
compile /pliant/install/ring2.pli (internals) 79 1
compile /pliant/install/ring2.pli (internals) 79 1
parse /pliant/install/ring2.pli (internals) 80 1
module /pliant/install/ring2.pli
compile /pliant/language/data/new.pli (internals) 17 1
compile /pliant/language/data/new.pli (internals) 17 1
compile /pliant/language/data/new.pli (internals) 17 1
compile /pliant/language/data/new.pli (internals) 17 1
parse /pliant/language/data/new.pli (internals) 20 1
module /pliant/language/data/new.pli
compile /pliant/language/unsafe.pli (internals) 18 1
compile /pliant/language/unsafe.pli (internals) 18 1
compile /pliant/language/unsafe.pli (internals) 18 1
compile /pliant/language/unsafe.pli (internals) 18 1
parse /pliant/language/unsafe.pli (internals) 19 1
module /pliant/language/unsafe.pli
compile /pliant/language/context.pli (internals) 16 1
compile /pliant/language/context.pli (internals) 16 1
compile /pliant/language/context.pli (internals) 16 1
compile /pliant/language/context.pli (internals) 16 1
parse /pliant/language/context.pli (internals) 17 1
module /pliant/language/context.pli
compile /pliant/fullpliant/run.pli (internals) 4 1
compile /pliant/fullpliant/run.pli (internals) 4 1
compile /pliant/fullpliant/run.pli (internals) 4 1
compile /pliant/fullpliant/run.pli (internals) 4 1
parse /pliant/fullpliant/run.pli (internals) 5 1
module /pliant/fullpliant/run.pli
----------------------------------------------------------------
processor stack content is:
error_notify_fatal (ErrorID Str) +14
error_report +61
error_renotify (ErrorID Address Str) +41
. compile (Expression) +125
  /pliant/fullpliant/run.pli (internals) 4 1
. execute (Expression) +21
  /pliant/fullpliant/run.pli (internals) 4 1
. execute (ParserContext) +51
parser_filter_execute +240
pliant internal parse_one_token function (ParserContext) +391
compile_text (List Module) +230
pliant_load_module (Str Module Int Module) +920
??? at 134599459
----------------------------------------------------------------
Message posted by hubert.tonneau on 2006/09/06 22:37:15
This probably means that default-debug1.dump file is missing in /pliant/binary/

Run
/pliant/fullpliant
to get it automatically created
instead of
pliant module /pliant/fullpliant/run.pli
which does basically the same but will not create it.
Message posted by maybe Marcus on 2006/09/07 04:38:12
I was able to start the server running the linux command from a users home directory

> pliant/fullpliant

However, as root, at the *same* machine, I am unable to start the server via the above command, or any other.
Message posted by maybe Marcus on 2006/09/07 20:39:24
I am lost.

In my last message I said I was able to run pliant on my machine as a normal user. I was not. The process
gets killed shortly thereafter (randomly, i.e., I don't have to visit the site for the process to get killed. It just 
dies, suddendly.

I have tried to start the server in verbose mode 2 three times, and got three outputs; each ends with a 
different message. To see the logs:

http://www.scs.ryerson.ca/m3santos/out.txt0
http://www.scs.ryerson.ca/m3santos/out.txt1
http://www.scs.ryerson.ca/m3santos/out.txt2

Message posted by hubert.tonneau on 2006/09/07 20:42:09
Could you email me the this_computer.pdb of the machine.