Newbie questions about Pliant

Newbie questions about Pliant

http_server options

I noticed that there have been several options available in
version 44 which are no longer available in 54:

pliant module /pliant/protocol/http/server.pli command 'http_server name a_string port a_string channel
a_string protocol_level a_string root a_string public a_boolean send_software_release_number a_boolean
maximal_form_length an_integer log a_string' (from 44)

Unfortunately, I've been unable to figure out how to get rid
of the default user authorization response, since 'public'
no longer appears to be supported. Also, 'root' doesn't seem
to be supported either, and changes made to the 'root' site config
using the one-shot configuration link don't seem to work either.

Any suggestions? It would be nice if there was a resource
for all the available settings in the various .pdb files, but
I've been unable to find one.

--Brian
Message posted by maybe Hubert Tonneau on 2001/01/15 17:15:05
See the new HTTP server documentation. You have to first start the HTTP
server using:

pliant module /pliant/protocol/http/server.pli command 'http_server configure'

Then go to 'Configuring the server' area, and select 'One shot configuration'
to build an initial set of files, or confire each section.
You can have a look at helio.pliant.cx configuration section as an example.
Message posted by maybe Brian on 2001/01/17 04:00:22
How does one disable the user authorization request?
Message posted by hubert.tonneau on 2001/01/17 09:43:09
You must define users and site in 'Configuring the server' section so that
'anonymous' user gets enough rights to read the site.
It should be done automatically if you use 'One short configuration'.

As an example, on 'helio.pliant.cx' configuration, the site has one line
specifying that browsing '/' requires 'everybody' right, and the 'anonymous'
user has one line (the one with id 'one shot') specifying that 'anonymous'
is always granted 'everybody' right.

Message posted by maybe Brian on 2001/01/17 17:11:15
OK, well, I just ended up deleting everything from /etc/pliant and starting over.
That seemed to do the trick.  But before I did that, I compared my site.pdb and users.pdb
file with the one at art.pliant.cx (most similar to my own setup), but found
no significant differences, so I still don't know why I kept getting the authorization
box.  At any rate, all appears to work fine now.  Thanks for the help.

  --Brian
Message posted by maybe Hubert Tonneau on 2001/01/17 18:00:09
One possible explaination is you had a space at the end of one of the
keywords in your configuration database.
When using the mouse and cut and past system, it is very frequent to have
a space at the end of a keyword and not notice it. Also, for Pliant
database system, 'everybody' is not at all the same as 'everybody '.