Newbie questions about Pliant

Newbie questions about Pliant

HTTP server

Message posted by naasking on 2001/01/17 23:50:47
I've installed Pliant and run the command exactly as specified in the docs:

http://helio.pliant.cx/pliant/welcome/run.html

but I just can't get it to start(I'm using release 55). The documentation said I could install pliant anywhere, so at first I tried installing it in /usr/local, but the server wouldn't start. It reported that it 'failed to load' server the module(the one I provided an explicit path to). I tried executing as an unpriviledged user and as root and I also tried establishing the server on port 8080 instead of 80; no dice. I even tried building it manually; still no good.

I then created a symlink /pliant pointing to /usr/local/pliant/pliant and that seemed to resolve the first issue, but I then ran into a host of other dependencies which couldn't be resolved. So I started from scratch and tried installing Pliant precisely as specified in the docs. The pre-built binaries still didn't work, even in /pliant. I just tried building it manually again(ie. with the 'install' script) and I finally got a prompt for name/password.

Any idea what I did wrong?
Message posted by maybe Patrice Ossona de Mendez on 2001/01/18 02:11:53
Do you have a pliant subdirectory in your home directory?
If yes, you should rename it, as it is choosen with priority to /pliant
(happened to me so many times...)
Message posted by maybe Hubert Tonneau on 2001/01/18 10:10:02
If Patrice advise does not solve your problem, could you cut and past here
a copy of your all session, including untarring.
Message posted by maybe Brian on 2001/01/18 22:11:58
Having been down that same road... :)

Might this be the problem:

/bin/pliant module /pliant/protocol/http/server.pl command 'http_server configure'
^^^^^^^^^^^        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     |               |
     |               this is relative to your /<somedir>/pliant dir!
     |
     |
     this is relative to your filesystem root directory
Message posted by naasking on 2001/01/20 21:27:31
I'll try and post the process I used and the errors I encountered by tonight. In response to somone's question, no I didn't have a pliant directory in my home directory.
Message posted by johan.boule on 2002/09/21 05:18:37
just a short message to tell you there is a little error in the documentation
concerning the http server:

http://pliant.cx/pliant/protocol/http/
section "Running the Pliant HTTP server"

the given command line is:
pliant 'precompile /binary/http.dump module /pliant/protocol/http/server.pli module /pliant/protocol/http/style/default.pli' module /pliant/protocol/http/server.pli command http_server

/pliant/protocol/http/style/default.pli should be .style
Message posted by maybe Hubert Tonneau on 2002/09/21 08:39:42
Corrected. Thanks.
Message posted by maybe Marcus on 2002/09/21 21:47:04
Corrected also at the PDI repository